Flash

· Tool for vector animation

· Vector- Images by the computer based on calculations of lines, files + other geometry.

· Raster- Pixel based (Make pixels larger or smaller)

· Advantages

· Streaming content

· Small files

· Interactivity and motion

· Flash player user sees exactly what you design (Consistent cross platform results)

· Disadvantages
· Flash for flash sake

· Users don’t have players or have old versions

· File Types

· .fla- development file (like a .psd in Photoshop)

· .swf- finished file

· Work Environment- Toolbox, Timeline, Default Panel Set, Property Inspector, Stage

· Property Inspector

· Shows Document Properties info about entire movie when nothing is selected (size, frame rate, background color)

· Shows specific info about object selected
· Default size- 550  * 400 Pixels

· Framerate- fps default 12
· Activity

· Go to Flash folder

· Create a folder called Work_In_Progress

· Open Flash

· File > New

· Change Bgcolor to #00FFFF

· Change framerate to 15

· Change size to 200 * 200

· Save as Movie1

· Stage

· Movie developed here- Place objects on stage as you want them to appear grey area stage called work area.
· Grids

· To make things line up: Go to view > Grids
· Rulers

· Measured in pixels
· Guides

· Drag from ruler
· Timeline

· Frames- not seconds
· Red line- play head (indicates on which frame you are working)
· Drawing

· Drawing tools- used to create shapes

· Arrow tool- Black arrow (Primary selection tool)
· Sub-selection tool- White arrow
· Open shared/Netweb/Flash MX/ RF_Flash/arrow.fla

· Select color in the circle w/ arrow tool (called fill)
· Select outside edge (this is stroke)
· Double click on inside to select both
· Deselect by clicking somewhere else or Edit > Deselect All
· Move arrow to outside edge (notice crescent)
· Click and drag
· Select the circle and stroke click on straighten in the tool options area until you have a triangle with one curved side
· Hover arrow over corner of square and drag a corner
· Save in you Work_In_Progress folder as arrow2.fla
· Oval, Rectangle tool

· Create perfect circle or square by holding down the shift key
· Round a rectangle by using the radius modifier in the tool options area
· Line Tool

· Draws strokes- cannot fill areas unless they are closed
· Pen Tool- Tricky and counterintuitive

· File > New (550 * 400), white background, 12 fps
· Set stroke to black + fill to light blue (#0099FF)
· Create a triangle by setting 3 anchor points on the left side of your stage
· Set an anchor point near the bottom of your triangle and to the right but after click drag your mouse tangent lines appear
· Bend your line and then complete the shape which should be similar to the teardrop
· Use the subsection tool to select the anchor point at the top
· Drag it down noticing how the curves are affected
· Save
· Brush Tool

· Brush tool only paints fill- you will not be able to fill anything you create with tool
· In the options area you will see brush modes: Paint Normal, Paint Fills, Paint Behind, Paint Selection, Paint Inside
· Brush size and shape modifier
· Pencil Tool

· Creates only strokes- closed areas can be filled, Straighten, Smooth, and Ink mode
· File > New
· Select oval tool- Hold shift to create circle
· Draw second circle from bottom right to top left (overlapping)
· Select fill on top circle with Arrow press delete
· Select stroke on top circle
· Select pen and create a curve with 2 anchor points
· Click and drag 3 more times to create other points, then close
· Select Brush- Sign first 1st name select pencil and sign last time
· Save as drawing.fla
· Gradients

· Radial and linear
· Paint bucket applies both gradients and solids
· Gradients can be created in the color mixer
· Open arrow2.fla
· In the color mixer select fill style, Radial Gradient: R 50, G 125, B 255, don’t change alpha
· Select Paint Bucket and fill ellipse
· Color Mixer- Linear Gradient create your own gradient color
· Add swatch on color mixer menu
· Select paint bucket and apply gradient to polygram
· Select Fill and transform and rotate fill
· Save as colors.fla
· Stroke

· Modified in property inspector color changed in color mixer
· File > New
· Select Rectangle
· Set stroke color FF0000
· Set fill color to Black
· Custom stroke style
· Ragged- Type


Wavy- Wave Height

8- Thickness
· Very Short- Wavelength

Dotted- Pattern
· Draw tall narrow rectangle
· Draw 2 other rectangles the intersect current to draw an F
· Use Arrow to select Portions that overlap and delete
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· Free Transform

· Scale, Rotate + Skew, Distort + Envelope
· Select one of these from the options area of the toolbox
· To use exact numerical values for these functions choose transform from the window menu and make changes in the transform panel
· Eraser

· 5 modes- Erase normal; Erase fills; Erase lines; Erase selected fills; Erase inside
· Erase shape- in bottom of tool box much like brush options choose appropriate shape for the job
· Faucet- allows you to erase large areas at once
· Lasso Tool

· Used to select irregular areas of a shape
· Magic Wand tool included in options area of tool box
· Color threshold determines how many similar colors to include 0 – 200 possible
· Polygon Mode
· Draws straight lines as you circle- when you have completed shape it will be selected
· Open colors.fla
· Select Erase
· Change eraser mode to erase fills
· Click + drag the eraser over the modified square to erase fill
· Select free transform
· Double click modified circle/select distort modifier
· Select top left + move it up to stretch + scale
· Select bottom right + drag to left
· Save file as colors2.fla
· Grouping

· 2 or more objects can be selected and modified at the same time
· Select objects + then modify > group from the main menu
· New document
· Select rectangle tool- property inspector stroke 1px; solid line; fill #00FF00 (bt. green)
· Create square
· Window > Info
· Double click (Select stroke + fill) / in Info panel set w + h to 50 click; top-left box (alignment squares set x+y to 25)
· Make sure stroke + fill are still selected / choose Modify > Group
· Edit > Copy; Edit > Paste (3 times for a total of 4 squares)
· Info panel
· 1st square copy- X:80, Y:80
· 2nd square copy- X:25 Y:80
· 3rd square copy- X:80 Y:25
· Arrow tool for select all 4 squares
· Save as squares.fla but leave it open
· Layers

· Much like Photoshop Flash uses layers
· Found to the left of the timeline
· Back to squares.fla
· Add layer by clicking “Insert Layer” icon in the bottom left hand corner
· Squares should still be selected / Edit > Copy / Select layer 2 + Edit > Paste
· Lock layer1 by clicking on the dot below lock icon on layer
· Free transform tool / move group of squares on layer 2 to right and scale them 4 times the original
· Double click grouped squares on layer 2 (Notice the timeline now indicates you are editing the group not Scene1)
· Double click bottom right square- fill to #0000FF
· Click Scene1
· Unlock layer1 and use arrow tool to select both sets of squares; Window > Align
Align Left Edge
· Drag layer 2 below 1 (small squares should be top of large square)
· Free Transform- rotate large 180 so blue square only shows
· Save as squares.fla (grade ?)
· Complete Space Shuttle (A-1) pg. 337

· Flash- Ch. 4 Symbols

· 3 types- Graphic, Movie Clip, Button
· Each occurrence is called an instance
· Library organizes all elements of a movie; Folders help with organization- Create one by selecting orange icon at bottom
· 2 methods for creating a symbol
· Draw directly on stage + convert symbol
· Create symbol, then add content
· Things that can be included in a symbol
· Shapes, imported images, video clips, sound clips, Actionscript, other symbols
· Graphic Symbols

· Hold static images (shapes, bitmaps)
· Create symbol in 2 ways
· Existing shapes- select object; Insert > Convert to Symbol
· New Symbol- Insert > New Symbol
· Edit Modes
· Standard symbol in edit mode
· Edit in Place
· Edit in new window


Create a new movie called comet.fla



Change the background color to #000066



Create a star in the upper right hand corner




To create a star choose the polystar tool (under the rectangle tool)




In the properties panel, choose options and choose “star” from the style menu



Right click on the star and choose “Convert to symbol”



Type should be graphic



Name it “comet”



Double click on the symbol to enter edit symbol mode (notice the gray bar now indicates you are editing the symbol)



Use the line tool to add lines to the back of your comet (indicating movement)



Click on scene 1 to return to the movie

Classic Tweening

· Frames- indicate an amount of time that elements should appear on the screen
· Key frames
· Indicates change along the timeline
· Inserted to add actions to a frame


Right click on frame 20 and insert a keyframe



Move the comet to the middle of the screen



If you like, use the transform tool to also make the comet larger



Create a keyframe in frame 40



Move the comet off of the screen on the bottom left of the screen



Use the free transform tool to shrink the comet



Click in the timeline between frame 1 and 20



Choose tween motion from the properties panel or right click and choose create motion tween from the menu



A black arrow and purple shading should appear in the timeline



Run your movie by choosing control>play, control>test movie or by hitting enter

Try it yourself


Create a file called summer.fla


Make blue sky and green grass


Create one large flower on the screen (should have petals and a pollen center)


Create 2 symbols (a bee and a butterfly)


In your movie, the bee should fly in from off screen and lite on the flower for a few frames and then fly off screen.  The butterfly should do the same thing.
Shape Tweening


Turns one shape into another





Use the text tool to write RRHS on the screen




Select Modify>Break Apart





Each letter should be surrounded by a box

                                           Select Modify>Break Apart



                          
If you look in the properties panel you should see that the word is now a shape





Click in frame 20





Insert a keyframe





Delete the RRHS





Type in dragons





Select Modify>Break Apart





Each letter should be surrounded by a box

                                            Select Modify>Break Apart

                                            It should now be a shape


                                     Right click on a frame between the two keyframes and insert a motion tween



Try it yourself




Create a file called shape.fla




Have your name morph into your descriptive word from the beginning of the year




Create a shape tween in each corner as well
Buttons and ActionScript

ActionScript is a programming language used in Flash to create interactivity with those viewing your Flash movie.  Because there are different audiences (designers and developers) they offer two types of ActionScript 2.0 (AS2) and ActionScript 3.0 (AS3).  We will use AS2, therefore when you create a new file and plan to use ActionScript you need to open an ActionScript 2.0 document.

Try it Yourself


        Create a new Flash movie (ActionScript 2.0)


        Draw a straight line across your screen with the line tool


        Create a new layer

               Use the rectangle tool to create a tall and skinny rectangle



Convert this to a symbol and move it to the left end of the line



Click on frame 50 and enter a keyframe



Create a classic tween between frames 1 and 50


        Insert a new button symbol called stop



Draw a red circle – click back on scene 1

  
        Insert a new button symbol called go



Draw a green rectangle – click back on scene 1


        Create a new layer called buttons



Insert your stop symbol and your go symbol in frame one of this layer


        Use the black arrow to select the go button


 
Click on Window>Actions



An actions panel should pop up



In the panel type the following code:




on (release) { play();}


        Return to scene 1


        Click on the stop button



Click on Window>Actions



An actions panel should pop up



In the panel type the following code:




on (release) { stop();}


        Return to scene 1


        Create a new layer called “actions”


        Select Frame 1 of this new layer



Click on Window>Actions



An actions panel should pop up



In the panel type the following code:




stop();

        Test your movie, the rectangle should not start across the black line until you click your go button, once you start it you should be         able to stop it by clicking on the stop button

